Startseite

Outlook | Excel | Word | PowerPoint | Adobe Acrobat DC | Blog

XING | Facebook |


Pia Bork
Training, Support, Coaching für Office und Filesite


 

Impressum und Datenschutz

Creative Commons License  

Tipps und Tricks rund um Excel

A B C D E F G H I/J K
L M N O P/Q R S T U-W X-Z

 

WENN für Texte

Die Funktion WENN wird eingesetzt, um eine Bedingung zu prüfen und dann je nach Ergebnis der Prüfung einen DANN-Wert oder einen SONST-Wert auszugeben oder zu errechnen.

Die Funktion benötigt drei Argumente:

=WENN(PrüfungDannSonst)

=WENN(D5>6500;"Wir gewähren 3 % Skonto";"Zahlbar ohne Abzug")

In der Rechnung rechts sollen in Zeile 6 zwei verschiedene Sätze ausgegeben werden:

  • Wenn die Summe in D5 größer ist als 6.500 Euro, dann soll geschrieben werden 
    Wir gewähren 3 % Skonto.
  • Wenn die Summe in D5 kleiner ist als 6.500 Euro, dann soll geschrieben werden 
    Zahlbar ohne Abzug.

 

Klicken Sie zuerst in Zelle C6 und tippen Sie =WENN(

Excel zeigt die WENN-Funktion an und fordert auf, als erstes die zu prüfende Zelle anzugeben.

 

Das ist in unserem Fall die Zahl in D5. Sie soll größer 6500 sein.

Tippen Sie D5>6500 und schließen Sie mit einem Semikolon die Prüfung ab.

 

 

Jetzt kommt der DANN-Wert, der ein Text ist. Darum muss er in Anführungszeichen eingeschlossen sein.

Tippen Sie "Wir gewähren 3 % Skonto" und schließen Sie wieder mit dem Semikolon ab.

 

Es folgt der SONST-Wert, der als Text auch wieder in Anführungszeichen muss.

 

 

Tippen Sie "Zahlbar ohne Abzug" und beenden Sie alles mit der schließenden Klammer.

Tipp: Falls Sie nicht Zahlbar ohne Abzug schreiben möchten, sondern gar nichts, tippen Sie zwei Anführungszeichen hintereinander ein.

Mit einer WENN-Funktion können Sie auch für Textlisten schnell die richtigen Angaben erzeugen. In der nebenstehenden Adressenliste wird das Geschlecht als m oder w erfasst. Daraus ermittelt Excel in der Spalte D die Anrede für die Briefanschrift und in der Spalte E die Anreden für den Brief.

 

Die Formel lautet für die Spalte D:

=WENN(A2="m";"Herrn";"Frau")

Alle Texte müssen Sie in Anführungszeichen fassen: also das m, Herrn und Frau.

In Spalte E steht die Formel in etwas abgewandelter Form.

=WENN(A2="m";"Sehr geehrter Herr ";"Sehr geehrte Frau ")

Die Bedingung A2="m" bleibt gleich, nur die Ausgabe für Dann und Sonst ändern sich. Merken Sie sich, ob Sie jeweils hinter ...Herr bzw. hinter...Frau einen Leerschritt schreiben oder nicht. Machen Sie es in beiden Fällen gleich!

Schreiben Sie die Formeln in die Zellen und füllen Sie die Formeln nach unten aus.

18.09.2013

 

Weitere WENN

3% Skonto berechnen

WENN verschachtelt

Download

Beispieltabelle mit Lösung