Startseite

Outlook | Excel | Word | PowerPoint | Adobe Acrobat CD | Blog

XING | Facebook |


Pia Bork
Training, Support, Coaching für Office und Filesite


 

Impressum und Datenschutz

Creative Commons License  

Tipps und Tricks rund um Excel

A B C D E F G H I/J K
L M N O P/Q R S T U-W X-Z

 

AGGREGAT

  1. Aufbau der Funktion
  2. Ignorieren von Fehlerwerten, Teilergebnissen und ausgeblendeten Zellen
  3. Der kleinste/zweitkleinste/drittkleinste Wert von ...

Seit Excel 2013 gibt es die Funktion AGGREGAT. Sie bietet - ähnlich wie TEILERGEBNIS - mehrere Berechnungsmöglichkeiten als Funktionsnummer an. Die Besonderheit: Mit AGGREGAT können Sie Fehlerwerte ignorieren und dennoch rechnen.

Der Aufbau der Funktion:

=AGGREGAT(Funktionsnr;Option;Bereich)
Die Funktionsnummer ist eine Zahl zwischen 1 und 19 für verschiedene Berechnungen wie SUMME (9) oder MITTELWERT (1) oder KKLEINSTE (15).
Die Option bestimmt, welche Werte ignoriert werden: ausgeblendete Zeilen und Fehlerwerte (7) oder TEILERGEBNISSE und Fehlerwerte (2).

Die "Option" ist der Grund, warum AGGREGAT so besonders ist. Unten ein Beispiel für eine Tabelle, in der Fehlerwerte auftauchen, die aber ignoriert werden sollen. Es soll immer die Summe der schon bekannten Endpreise gezeigt werden. SUMME kann das nicht und liefert einen Fehler - AGGREGAT kann mit der Option 6 diese Fehler einfach übergehen)

Berechnung mit =SUMME(C2:C5)

Berechnung mit =AGGREGAT(9;6;C2:C5)

 

 

Folgende Optionen gibt es:

0

Geschachtelte TEILERGEBNIS- und AGGREGAT-Funktionen ignorieren

1

Ausgeblendete Zeilen, geschachtelte TEILERGEBNIS- und AGGREGAT-Funktionen ignorieren

2

Fehlerwerte, geschachtelte TEILERGEBNIS- und AGGREGAT-Funktionen ignorieren

3

Ausgeblendete Zeilen, Fehlerwerte, geschachtelte TEILERGEBNIS- und AGGREGAT-Funktionen ignorieren

4

Nichts ignorieren

5

Ausgeblendete Zeilen ignorieren

6

Fehlerwerte ignorieren

7

Ausgeblendete Zeilen und Fehlerwerte ignorieren

 

"Ausgeblendete Zeilen ignorieren" (5) funktioniert genauso wie bei TEILERGEBNIS. Es wird nur gerechnet, was ich sehe. Sie kennen das Verhalten vermutlich aus einer formatieren Tabelle.

"Geschachtelte Teilergebnisse ignorieren" (0, 1, 2 und 3) addiert nur Zahlen, aber keine bereits vorhandenen Zwischensumme - sofern die mit TEILERGEBNIS erstellt wurden. Das kann man auch erreichen mit der AutoSumme. In den Zellen B11, B21 und B28 sind mit =TEILERGEBNIS(9;...) Zwischensummen erstellt worden.

Klick auf das Symbol "AutoSumme"

=AGGREGAT(9;1;B2:B28)

In beiden Fällen bekommt man das gleiche Ergebnis: 371.527 €. Vorteil von AGGREGAT auch hier wieder die Möglichkeit, Fehlerwerte zu ignorieren. Wenn ich statt der Option "1" die "2"oder "3" verwende, werden nicht nur Teilergebnisse ignoriert, sondern auch Fehlerwerte.

15.12.2016

Download

Beispieltabelle zum Ausprobieren (Excel 2016, gezippt)