Startseite

Outlook | Excel | Word | PowerPoint | Adobe Acrobat CD | Blog

XING | Facebook |


Pia Bork
Training, Support, Coaching für Office und Filesite


 

Impressum

Creative Commons License  

Tipps und Tricks rund um Excel

A B C D E F G H I/J K
L M N O P/Q R S T U-W X-Z

 

ZELLE - Informationen abfragen

Die Funktion ZELLE liefert Informationen über eine Zelle wie zum Beispiel über die Zahlformatierung (Datum, Text, Zahl), die Ausrichtung (links, zentriert) oder die Tatsache, dass negative Zahlen rot formatiert sind.

Die Schreibweise ist:

=ZELLE("Infotyp";Bezug)

Alle Infotypen müssen in Anführungszeichen gesetzt werden.

=ZELLE("Format";A1)

Geben Sie keinen Bezug an, wird die Information über die zuletzt veränderte Zelle angezeigt.

Achtung! Die Funktion ZELLE aktualisiert sich nicht immer automatisch, wenn Sie Inhalte ändern oder wenn Sie die Formel kopieren. Beim Neuformatieren einer Zelle wird der Rückgabewert nie aktualisiert. Sie müssen F9 drücken, damit eine Neuberechnung durchgeführt wird.

Sie können sich über folgende Zustände informieren:

Infotyp Erklärung Beispiel
Adresse Bezug der Zelle für Zelle A1: A1
Spalte Spaltennummer der Zelle für B7: 2
Farbe Prüft, ob negative Werte farbig sind neg. Werte rot: 1
Inhalt gibt den Inhalt ohne Format 31.05.2014: 41790
Dateiname Name und Pfad der Tabelle C:\mappe.xlsx
Format Zahlenformat (siehe separate Tabelle) Standard: S
Datum je nach Schreibweise D1 bis D5
Klammern Prüft, ob positive Werte in Klammern stehen keine Klammern: 0
Präfix Ausrichtung in der Zelle zentriert: ^
Schutz Prüft, ob die Zelle geschützt ist ungeschützt: 0
Zeile Zeilennummer der Zelle für Zelle B7: 7
Typ Prüft, ob die Zelle Text, Werte oder nichts enthält Leere Zelle: b
Breite Breite der Spalte 14

 

Eine Beispieltabelle mit den wichtigsten Informationen können Sie sich im Download-Bereich oben rechts herunterladen.

Die Rückgabewerte für ein Datum sind D1 bis D5, aber einige Datumsschreibweisen werden von Excel als "Standard" zurückgegeben.

Datum Schreibweise Rückgabewert
29.05.2014 TT.MM.JJJJ D1
2.6.2014 T.M.JJJJ D1
03.06.14 TT.MM.JJ D1
04 Jun 2014 TT MMM JJJJ D1
05 Juni 2014 TT MMMM JJJJ D1
Juni 14 [$-407]MMMM JJ;@ D1
09/06/2014 TT/MM/JJJJ D1
30.05 TT.MM D2
10/06 TT/MM D2
Juni 2014 MMMM JJJJJ D3
06/11 MM/TT D5
Sa 31.05.2014 TTT TT.MM.JJJJ S
Sonntag, 1. Juni 2014 [$-F800]TTTT, MMMM TT, JJJJ S
2014-06-08 JJJJ-MM-TT S

 

Um mit einem Rückgabewert weiterzurechnen, muss er in Anführungszeichen gesetzt werden. Beispielsweise will ich abfragen, ob eine Zelle ein Datum enthält und dann zum Datum 10 Tage addieren. Das Datum steht in Zelle A1.

=WENN(ZELLE("Format";A1)="D1";A1+10;"")

Wenn der Rückgabewert für das Format gleich "D1" ist, dann addiere zu A1 zehn Tage, ansonsten rechne nichts.

Um alle Datumsschreibweisen von D1 bis D5 abzufragen, schreiben Sie es so:

=WENN(UND(ZELLE("Format";A1)>"D0"; ZELLE("Format";A1)<"D10";A1+10;"")

Größer "D0" und kleiner "D10" wird berücksichtigt. Da bei Microsoft kein Wert größer als D5 erwähnt wird, gehe ich davon aus, dass es gewiss nicht mehr als zehn mögliche Rückgabewerte für das Datum gibt.

Hier sehen Sie einige mögliche Rückgabewerte für "Format", "Farbe", "Typ" und "Klammern". Die vollständige Tabelle können Sie sich im Downloadbereich herunterladen.

Eintrag Zahlformat Format Farbe Typ Klammern
Text Text S 0 l 0
1234 Standard S 0 w 0
1234 Zahl keine Nachkommastelle F0 0 w 0
1234,00 Zahl 2 Nachkommastellen F2 0 w 0
-1.238 Zahl negative Zahl rot .0- 1 w 0
(1.234) Zahl negative Zahl in Klammern .0- 1 w 0
(1.234) Zahl positive Zahl in Klammern .0() 0 w 1
    1.234,00   Buchhaltung .2 0 w 0
10% Prozent keine Nachkommastelle P0 0 w 0
15,9% Prozent eine Nachkommastelle P1 0 w 0
   1.234,00 € Währung Euro W2 0 w 0
$1.235,00 Währung Dollar .2 0 w 0

 

Sie sehen, dass Text und Standard beim "Format" jeweils als "S" zurückgegeben werden. Die Unterscheidung, ob Text oder Zahl kann besser mit dem "Typ" erfolgen. Texte werden mit "l" wie Label und Ziffern werden als "w" wie Werte zurückgegeben. Eine leere Zelle wird als "b" (blank) gekennzeichnet.

Der Infotyp "Farbe" bezieht sich auschließlich auf die Farbe der negativen Zahlen.

29.05.2014

Download

Beispieltabelle mit den wichtigsten Informationen (Excel 2010, gezippt)

Anwendung

Eine weitere Anwendung ist die Verwendung des Blattnamens in einer Formel