Startseite

Outlook | Excel | Word | PowerPoint | Adobe Acrobat DC | Blog

XING | Facebook |


Pia Bork
Training, Support, Coaching für Office und Filesite


 

Impressum und Datenschutz

Creative Commons License  

Tipps und Tricks rund um Excel

A B C D E F G H I/J K
L M N O P/Q R S T U-W X-Z

 

SVERWEIS Spalte ermitteln

In den SVERWEIS-Grundlagen haben Sie gesehen, dass die Spalte immer angegeben werden muss.

=SVERWEIS(Suchkriterium;Matrix;Spaltennr.;Bereich_Verweis)

=SVERWEIS(B3;Gebühren;2;FALSCH)

In der Tabelle "Gebühren" gibt es vier Spalten; die Tabelle wurde wieder als formatierte Tabelle angelegt, sie hat den Namen "Gebühren".

  • Spalte 1 (A): Gewicht; danach wird als Kriterium gesucht
  • Spalte 2 (B): Preis für die erste Zone
  • Spalte 3 (C): Preis für die zweite Zone
  • Spalte 4 (D): Preis für die dritte Zone

 

Auf einem anderen Blatt ist werden die Gebühren anhand von Gewicht und Zone berechnet.

 

 

Abhängig von der eingebenen Zone soll Excel nun entweder aus der zweiten, der dritten oder der vierten Spalte den Preis ermitteln.

Es muss also zur Zone, die in B2 eingegeben wird, jeweils die Zahl 1 addiert werden, um den korrekten Preis zurück zu bekommen.

Die Formel sieht so aus:

=SVERWEIS(B1;Gebühren;B2+1)

 

So lesen Sie die Formel:

Die Preise verstehen sich wieder "von - bis". Ein Brief, der 450 g wiegt kostet in Europa also 2,50 € - er wiegt zwischen 100 g und 500 g und es gilt der Preis von 100 g. Darum können wir auf das Argument Bereich_Verweis hier verzichten - oder Sie geben WAHR an.

19.09.2013

Download

Beispieltabelle mit Lösung